Trust Centers failing to load intermittently

Incident Report for Vanta

Resolved

Fix has been implemented
Posted Dec 01, 2023 - 08:01 PST

Identified

Some customers may see error pages due to cached values in their custom domain Trust Center. A fix is being deployed.
Refreshing the page should resolve the issue until the fix is released.
Posted Dec 01, 2023 - 07:30 PST
This incident affected: Vanta Web App (Trust Center).