Links to the Trust Center from Vendor Profile leads to incorrect page for EU accounts
Incident Report for Vanta
Resolved
A fix has been implemented and the issue has been resolved
Posted Jan 30, 2024 - 12:54 PST
Identified
We have identified an issue where the links to Trust Centers from within the Vendor Risk Management table are directed to incorrect pages for EU customers. The team is working on a fix and will provide updates when available.
Posted Jan 30, 2024 - 10:57 PST
This incident affected: Vanta Web App (Vendor Risk Management).