Issues when uploading resources to Trust Centers
Incident Report for Vanta
Resolved
This incident has been resolved.
Posted May 28, 2024 - 15:10 PDT
Identified
We’re working on resolving issues uploading resources to the Trust Center
Posted May 28, 2024 - 13:11 PDT
This incident affected: Vanta Web App (Trust Center).