This incident has been resolved. HR users and accounts have been restored.
Posted Sep 10, 2025 - 16:47 PDT
Update
The Engineering team has successfully re-linked HR accounts and is currently actively working to restore links to Access accounts.
Posted Sep 09, 2025 - 09:10 PDT
Update
All of the missing users from Google Workspace(GSuite) should now be restored on the People page. The Engineering team is currently actively working to restore links to HR accounts and Access accounts.
We will continue to keep you updated on our progress towards complete resolution.
Posted Sep 03, 2025 - 11:58 PDT
Identified
Some users may be missing users synchronized from Gsuite. We deployed a fix for the Gsuite integration, and are re-synchronizing all impacted accounts. Users will be automatically restored when this process completes.
Posted Sep 03, 2025 - 05:28 PDT
Investigating
We have identified an issue with GSuite users syncing and are deploying a fix. GSuite users are expected to be synchronised automatically.