Trust Collaborator users unable to view internal Access Requests page

Incident Report for Vanta

Resolved

This incident has been resolve and Trust Collaborator should no longer receive an error on the Access Request page.
Posted Jul 09, 2025 - 10:39 PDT

Identified

We have identified an issue where users with the Trust Collaborator role are receiving a permissions error when attempting to view the internal Access Requests page.

Our team has identified the issue and is actively working on a fix. We will provide updates as soon as they become available.
Posted Jul 09, 2025 - 09:31 PDT
This incident affected: Vanta Web App (Trust Center).