Bitbucket integration connection issues

Incident Report for Vanta

Resolved

The fix has been deployed and the Bitbucket integration is connecting normally again. Customers who previously encountered the "unknown error" while trying to connect Bitbucket should now be able to successfully complete the connection flow by retrying.
Posted Apr 22, 2026 - 14:37 PDT

Identified

We have identified the cause of the Bitbucket integration connection failures affecting a some customers. A fix has been developed, tested, and is currently being deployed. Customers with existing Bitbucket connections have not been affected. Once the deployment completes, customers who previously hit this error will need to retry connecting their Bitbucket integration.

We will post another update once the fix is fully rolled out.
Posted Apr 22, 2026 - 12:59 PDT

Investigating

We are currently investigating an issue preventing customers from connecting the Bitbucket integration. Users attempting to authorize Vanta against Bitbucket are being redirected back with an "unknown error." Existing Bitbucket integrations are unaffected — only new connections are failing.
Our engineering team is actively investigating, and we will provide another update as soon as we have more information.
Posted Apr 22, 2026 - 08:26 PDT
This incident affected: Vanta Web App (Core App).