Trust collaborators seeing errors on the "Viewers granted access" page

Incident Report for Vanta

Resolved

This incident has been resolved, and Trust Center for Trust Collaborators should be functioning as expected.
Posted Mar 16, 2026 - 16:08 PDT

Identified

The issue has been identified and our Engineering team is actively working on a resolution.
Posted Mar 16, 2026 - 10:21 PDT
This incident affected: Vanta Web App (Trust Center).