This incident has been resolved, and email delivery should be functioning as expected.
Posted Oct 24, 2024 - 20:17 PDT
Monitoring
A fix has been implemented and email delivery times are beginning to return to expected levels. The team will continue to monitor.
Posted Oct 24, 2024 - 19:46 PDT
Update
The team identified an issue with the latest fix and reverted it. A new fix has been published to mitigate the message delay issue. ETA to land in production ~45 minutes.
Posted Oct 24, 2024 - 18:31 PDT
Update
The fix has been deployed and will be live in around one hour.
Posted Oct 24, 2024 - 17:50 PDT
Update
Vanta's vendor for email delivery has identified the issue and is rolling out a fix for the message delays.
Posted Oct 24, 2024 - 17:19 PDT
Identified
We have identified an issue Vanta's vendor for email delivery is experiencing an incident, customers may see delays in email delivery including login links affecting all Vanta customers.
This started happening around 15:38 PDT, and most recently they shared at 16:29 PDT saying they're still investigating.