'Something went wrong' error when accessing Risk > Snapshots page

Incident Report for Vanta

Resolved

This incident is now resolved.
Posted Jul 21, 2025 - 08:55 PDT

Identified

Our Engineering team has identified the issue and is actively working on a fix.
Posted Jul 21, 2025 - 07:56 PDT

Investigating

We have identified an issue where customers are receiving a 'Something went wrong' error when attempting to load the Risk > Snapshots page, affecting all customers.

Our team is investigating the root cause and will provide an update as soon as possible.
Posted Jul 21, 2025 - 07:34 PDT
This incident affected: Vanta Web App (Core App).