Vanta Application Unable to Load

Incident Report for Vanta

Resolved

This incident has been resolved and Vanta app should now load for all users.
Posted Nov 10, 2025 - 14:38 PST

Monitoring

We’ve finished our mitigation efforts, and latency metrics have returned to normal. We’re continuing to monitor app performance.
Posted Nov 10, 2025 - 13:38 PST

Identified

We’ve identified the root cause and are actively working on mitigations. The Vanta application should now load for users although latencies remain high
Posted Nov 10, 2025 - 12:06 PST

Update

We're currently investigating the issue, and will provide an update soon.
Posted Nov 10, 2025 - 11:47 PST

Investigating

We're currently experiencing a major performance regression resulting in the Vanta application being unable to load. We are actively working to mitigate.
Posted Nov 10, 2025 - 11:40 PST
This incident affected: Vanta Web App (Core App).