Delayed HR results from Finch-powered HRIS integrations
Incident Report for Vanta
Resolved
Finch has resolved their scheduler issues over the weekend and updates are now within SLA.
Posted Jan 17, 2023 - 14:25 PST
Monitoring
HR results from our Finch-powered integrations are running behind, which may cause outdated HR info. We're currently monitoring the situation and working with Finch to restore regular syncs.
Posted Jan 13, 2023 - 12:21 PST
This incident affected: Third-Party Connections (Other Third-Party Connections).