Intermittent issues loading Trust Center and Questionnaire Automation

Incident Report for Vanta

Resolved

This incident has been resolved.
Posted Mar 18, 2024 - 09:41 PDT

Monitoring

We have seen the response times come back to normal and are continuing to monitor the behavior. We will continue to provide updates as they become available.
Posted Mar 18, 2024 - 09:21 PDT

Investigating

We have identified an issue loading Trust Center and Questionnaire Automation intermittently affecting all customers.

Our team is investigating the root cause and will provide an update as soon as possible.
Posted Mar 18, 2024 - 08:44 PDT
This incident affected: Vanta Web App (Questionnaire Automation, Trust Center).